Tuesday, October 21, 2014

Yosemite issue

As you might have tried, CasualConc and other applications do not run on OS X 10.10 Yosemite. This is because my applications are written in RubyCocoa, which depends on Ruby 1.8.x. But Apple decided to drop Ruby 1.8.7 on Yosemite (Ruby 2.0.0 is there).

I'm working with the maintainer of RubyCocoa to work around this issue (most likely apps will include a port of Ruby 1.8 within the apps). So far, I have successfully run it on Yosemite, but haven't had time to test it. If you are interested in helping testing the functionality on Yosemite, please email me to the address on the site.

No comments: